32 lines
931 B
Text
32 lines
931 B
Text
# Contributor: Nulo <alpine@nulo.in>
|
|
# Maintainer: Nulo <alpine@nulo.in>
|
|
pkgname=stacktile
|
|
pkgver=0.1.1
|
|
pkgrel=0
|
|
pkgdesc="Layout generator for the river Wayland compositor."
|
|
url="https://git.sr.ht/~leon_plickat/stacktile"
|
|
license="GPL-3.0"
|
|
arch="all"
|
|
makedepends="
|
|
wayland-dev
|
|
wayland-protocols
|
|
scdoc
|
|
"
|
|
subpackages="$pkgname-doc"
|
|
source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~leon_plickat/$pkgname/archive/v$pkgver.tar.gz
|
|
fix-makefile.patch"
|
|
builddir="$srcdir/$pkgname-v$pkgver"
|
|
options="!check" # no test suite
|
|
|
|
build() {
|
|
make PREFIX=/usr
|
|
}
|
|
|
|
package() {
|
|
make DESTDIR="$pkgdir" PREFIX=/usr install
|
|
}
|
|
|
|
sha512sums="
|
|
72416d3aaaba94f8c0b4ff24aa658d354be5478158fd4086d71e781fa4d05fe357a98e26f341d064f2ce04737ab74b5789776dd3f24676251fe9350fd8e42e1f stacktile-0.1.1.tar.gz
|
|
e45f6a80cf17c7bc466ba7b15d0f4d01063a704299bf595ab7e07071e4bdd8fc7703e0144aa2bf1dd4634f7d5461c13235c873277767a12d4667925c7391de6c fix-makefile.patch
|
|
"
|