39 lines
882 B
Text
39 lines
882 B
Text
# Contributor: Nulo <alpine@nulo.in>
|
|
# Maintainer: Nulo <alpine@nulo.in>
|
|
pkgname=wbg
|
|
pkgver=1.0.2
|
|
pkgrel=0
|
|
pkgdesc="Super simple wallpaper application for Wayland compositors implementing the layer-shell protocol"
|
|
url="https://codeberg.org/dnkl/wbg"
|
|
arch="all"
|
|
license="MIT"
|
|
depends=""
|
|
makedepends="
|
|
meson
|
|
|
|
pixman-dev
|
|
wayland-dev
|
|
libpng-dev
|
|
libjpeg-turbo-dev
|
|
|
|
wayland-protocols
|
|
tllist-dev"
|
|
checkdepends=""
|
|
install=""
|
|
subpackages=""
|
|
source="$pkgname-$pkgver.tar.gz::https://codeberg.org/dnkl/wbg/archive/$pkgver.tar.gz"
|
|
options="!check" # no test suite
|
|
builddir="$srcdir/$pkgname"
|
|
|
|
build() {
|
|
abuild-meson . output
|
|
meson compile -C output
|
|
}
|
|
|
|
package() {
|
|
DESTDIR="$pkgdir" meson install --no-rebuild -C output
|
|
}
|
|
|
|
sha512sums="
|
|
4f8b80f69996a726eaeaed2974bac6fbda061f0f188442edf1e3ee933d5fcd2f0db3d6db31f538d9dae4de05f63d36f5c2df2ec7ddfa75d7634c521daae62996 wbg-1.0.2.tar.gz
|
|
"
|